Wiko U Feel Prima bootloader unlock failed (unknown command)

Dear all,
I have made numerous attempts to unlock the bootloader of my Wiko U Feel Prime, but to no avail.
(My goal is to flash TWRP, root with Magisk and install LineageOS.)
USB debugging and OEM unlocking are enabled in the developer settings.
ADB recognises the device. When I execute adb reboot bootloader, the device reboots, and doesn't get past the "powered by Android" screen – but is nonetheless found by fastboot when I run fastboot devices. Seems like the USB drivers are functioning properly, correct?
Now, when I run fastboot oem unlock, I get the following response:

Code:
... FAILED (remote: unknown command) finished. total time: -0.000s

The command fastboot flashing unlock gives the same result.
Moreover, fastboot getvar all displays no unlocked variable. The command fastboot getvar unlocked yields

Code:
unlocked:

By the way, this phone was shipped SIM unlocked.
I've spent hours looking around the web for solutions, but everyone (including guides specifically written for Wiko U Feel Prime) simply says "unlock the bootloader" as if it's a trivial task. And I've run out of ideas. Could anyone help?
Thank you very much.

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by vmaggio
4 hours ago
Last post by glarkin
39 minutes ago
Last post by casper.miguel
25 minutes ago
Last post by buford33
59 minutes ago
Last post by lenny.wyman
3 hours ago
Last post by lmedhurst
4 hours ago
Last post by vweissnat
3 hours ago