[Q] You are attempting to build with an unsupported version of java.

Sorry if i open thread to wrong section

im getting this error when typed

make -j4 otatools

Code:
:~/android-sdk-linux/platform-tools$ make -j4 out/host/linux-x86/bin/unpackbootimg ============================================ PLATFORM_VERSION_CODENAME=REL PLATFORM_VERSION=4.1.2 TARGET_PRODUCT=full TARGET_BUILD_VARIANT=eng TARGET_BUILD_TYPE=release TARGET_BUILD_APPS= TARGET_ARCH=arm TARGET_ARCH_VARIANT=armv7-a HOST_ARCH=x86 HOST_OS=linux HOST_OS_EXTRA=Linux-3.13.0-29-generic-x86_64-with-Ubuntu-14.04-trusty HOST_BUILD_TYPE=release BUILD_ID=JZO54K OUT_DIR=/home/blttalas/android-sdk-linux/platform-tools/out ============================================ Checking build tools versions... ************************************************************ You are attempting to build with an unsupported version of java. Your version is: java version "1.7.0_55". The correct version is: Java SE 1.6. Please follow the machine setup instructions at https://source.android.com/source/download.html ************************************************************ ************************************************************ You are attempting to build with the incorrect version of javac. Your version is: javac 1.7.0_55. The correct version is: 1.6. Please follow the machine setup instructions at https://source.android.com/source/download.html ************************************************************

How can i fix this issue?

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by alva15
1 hour ago
Last post by ondricka.johann
36 minutes ago
Last post by zpaucek
1 hour ago
Last post by jude56
55 minutes ago
Last post by tswift
47 minutes ago
Last post by evon
4 hours ago
Last post by liam92
49 minutes ago