SD Not being recognized. Need help!

Hey there guys,

Well, I got into a serious problem with my SD and I would really appreciate any help.
First of all, I got a Lg Magna H502 with the android 5.0.1, stock ROM. I managed to root it and then I got it into a bootloop by installing stupid things on it. (I'm pretty noob at android management). With TWRP I wiped everything that I could - totally desperate at this point. Bricked the hell out of it. Then, I couldn't even acess the TWRP.
Later, I managed to flash a mm ROM on it and all went back working again.. but with a big problem though, my SD wasn't being recognized anymore. It doesn't seem like a common problem, cuz I tried all the solutions that I could possibly find in the internet for 2 days and yet, no lucky. The problem isn't on the SD since my other device and my pc with the adapter can find it. Already tried formating with exFAT and FAT32, also tried the cmd checking method with the "chkdsk etc", it seems to be everything ok with the SD. Not only that, already tried to wipe cache and mount the sd card using the TWRP but still, nothing happens. It doesn't allow me to mount it.
I didn't try to flash the old stock ROM on it because all the people that installed the same mm ROM on the same phone didn't have this issue. So, it doesn't seems to be a ROM problem.
Any ideas? I can't figure it out.
The SD model is a Sandisk 32GB.

Thanks in advance!

Some screenshots:
image.prntscr.com/image/ 2c13e006b2e44617a82162ba59afcfe7.png
image.prntscr.com/image/ 19cc72551869400bb7a29681a624ecce.png

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by jayden96
3 hours ago
Last post by harris.lorenzo
32 minutes ago
Last post by kbauch
4 hours ago
Last post by prosacco.wallace
1 hour ago
Last post by delpha48
3 hours ago
Last post by nicklaus58
42 minutes ago
Last post by hodkiewicz.torrey
1 hour ago
Last post by eweimann
4 hours ago
Last post by jacky46
3 hours ago
Last post by jacky66
3 hours ago