Desire 530 turns of and then doesnt boot anymore.

First of all. My specs:
----------------------------
Android 6.0.1 Stock rom
hTC desire 530 (a16ul)
Unlocked bootloader
TWRP
Xposed (modules are: Gravitybox)
modified build.prop to disable navbar (qemu.hw.mainkeys=1)
----------------------------
these are my normal specs im using on it since its rooted. im always restoring an system.img i extracted from an ruu once.

Explaining my problem:

i modified the build.prop to diable the navbar to use pie (i want to have more screen for apps )
My Phone does get buggy after using it 1 month with an fresh rom, this ONLY happens when using keyboard for example:
im using my phone normal and then writing a message, everything is fine until my keyboard wont open to write the message.
I go to my home screen and try to open it on another place, doesnt work. after 1 minute screen gets black and my phone turns off.
when turning on it shows the white htc splash screen and then turns black. nothing even after 30 minutes of waiting. i can reboot into twrp and bootloader and download mode.
rebooted into twrp. flashed my boot.img and system.img and it works again.
After 1 month of using it again with the moded build.prop and xposed its doing the same.
another month later. the same.

ill make an comment with my build.prop as im new and cant post an pastebin link

as you may notice there is an qemu.hw.mainkeys option twice in the prop.
one on the bottom and on somewhere in the middle.
when using the with the one on the bottom inserted it happens after arround 1 month.
when moding the already existing value it completely bugs out and wont even allow me to unlock my screen anymore.

i think it has something todo with that value.
BUT
i deleted my build.prop via twrp and moved a stock one (extracted from the system image) into the system folder but it didnt turn on after that again .
i also uninstalled xposed via the xposed uninstaller.zip but it doesnt help.

idk what todo now.
maybe someone here can help me.
but thanks already for everyone that tries to help me.

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by tamara.heaney
3 hours ago
Last post by weber.allen
2 hours ago
Last post by bahringer.larue
1 hour ago
Last post by estrella.raynor
2 hours ago
Last post by lehner.katharina
3 hours ago
Last post by aurelia.schuppe
26 minutes ago
Last post by stephany77
4 hours ago
Last post by edison78
4 hours ago
Last post by howe.mireille
2 hours ago
Last post by ckessler
2 hours ago
Last post by mitchell.kevin
1 hour ago
Last post by zmaggio
3 hours ago