[Q]Urgent - Rogers Captivate phone has AT&T firmware after ODIN 2.2 upgrade

Well, I think I'm deep poo.

I'll save the introduction, being a new member, for later, and focus on an urgent problem that needs help.

Basically, being stuck on 2.1, I tried to find the easier way to upgrade my Captivate to 2.2. My Kies didn't work (even though I tried many solutions), so I had to find new ways to update my phone to Froyo. Take note that my Captivate is locked on Rogers (meaning I have a SIM card inside already). Also, my phone isn't rooted.

I stumbled upon this; "considering I can't post links, I'll give the directions for you, so you find the page I'm talking about; it's on techpetals.net and the article name is "How to Install Froyo on Captivate – Android 2.2 Froyo for Samsung Captivate Leaked"

I completed all the steps and this is where the problem shows its ugly face.

The HUGE problem comes from the fact that my phone is now like a stock, locked AT&T phone. What I mean by that is that the boot screen shows the AT&T logo. Everything is stock, such as in the early AT&T Captivate YouTube review. All my contacts are probably lost (I hope there's a way to retrieve them back). I can blame myself, as much as I can blame the author of the article who didn't mention that the solution only applied to US phones (likely). At least the menu shows that the firmware's 2.2.

I'm in limbo and I don't know what to do. There are so many things to fix here. I don't know what to do and I urgently need your help. What should I do, people?

Any kind of help would be appreciated.

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by adam43
2 hours ago
Last post by justen.ortiz
48 minutes ago
Last post by wilfredo17
37 minutes ago
Last post by mariana23
1 hour ago
google play
Started by qkiehn
Last post by olen59
4 hours ago
Last post by hlemke
59 minutes ago
Last post by rosamond.gaylord
17 minutes ago