[Q] Sansung Galaxy S2 SHW-M250S Network Problem

Hi All,
I have got Samsung Galaxy S2 ( SHW-M250S , with Android 4.0.4) from Korea through my friend. When I inserted Airtel SIM, it recognized this and I got the signal. But after couple of hours it started showing "No Service" . After restart it shows full network and lasts for few hours. I have observed, if I keep my data network (3G) ON , the issue is less frequent, I have observed maximum duration of 15-20 hours phone works fine before showing this problem. I have tried using BSNL SIM but problem is the same. There is no signal issue in my area because the SIM works perfectly in other phones.

I have observed another behavior : during the "No Service" condition, when I try to call some number I get "Network Not Available" error, If try this couple of times, I get signal back but it lasts only for few minutes ( this happens few times but not always). As I have mentioned above, I if restart my phone, it works without any problem for a longer duration.

This is used phone and there is no warranty for this. I desperately need some help to resolve this problem. I hope there is no issue with the hardware.

Attached are screen shots of the software version.

Thanks in advance
SK



Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by elsie.berge
2 hours ago
Last post by harvey.birdie
4 hours ago
Last post by davin46
4 hours ago
Last post by dayne.grimes
42 minutes ago
Last post by vernice61
3 hours ago
Last post by jamel19
3 hours ago
Last post by art.roob
14 minutes ago
Last post by jeremy42
4 hours ago
[Q]
Started by dylan17
Last post by coy.botsford
4 hours ago
Last post by morar.taurean
13 minutes ago
Last post by ulemke
2 hours ago