Could the 4.4.2 update have messed up my Galaxy Note 10.1?

So over here in Australia, we have only just received the 4.4.2 kit Kat update for the Galaxy Note 10.1 2014 edition (WiFi and 4g) (p605xxucnj2). I installed it a couple of weeks ago and now even the most basic things on my tablet are messed up.

Let's be clear - I don't download dodgy apps or games or anything. But now since the update I am plagued by problems.

The most troubling issue is that I cannot access the Google Play Store. After trying a few different things, I uninstalled all app updates, then tried to access it again. Still no-go. (just a perpetual loading sign). Without the Google Play Store I cannot update or download any new apps. This is worrisome because I am starting university soon and the whole reason I bought this (expensive) tablet was for it to act as my 'laptop'.

The YouTube app will only work once in a blue moon. Otherwise, it is the same as the play store - the app will open and the bar at the top will come up but nothing will load.

My emails cannot sync either. I can link my yahoo account and it will recognize different folders but I can open any folder and nothing will load. It will either tell me that the folder is empty or, again, it will load forever.

Facebook is patchy at best. Usually if I've restarted the device it will load, but the news feed, messages and notifications will then refuse to refresh (or it will insist that it has refreshed, when really is hasnt).

Also, I cannot download files from the Internet. Word documents, music, email attachments such as images. (however I can go on Google images and save images just fine - I just can't say enough email attachments.)

I can't access Google Play Store via the Internet and download apps remotely either - location services cannot pick up my device even if I have WiFi, mobile data/4G on - the works! However I can still install apps remotely to my mobile phone, another android that shares a Google account - therefore it is not the fault of the account but the device.

If I had multiple tabs open in my last browsing session, Google Chrome sometimes will only reopen one of them. This is more an inconvenience, if anything.

Other apps such as Tumblr are slowed.

Please, please help!! If you need anymore information about the device to make a diagnosis/recommendation, just say so

Many many many thanks, Alex

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by shakira23
4 hours ago
Last post by andreanne.rohan
3 hours ago
TW
Started by nolan.kuhic
Last post by jazmyne77
4 hours ago
Last post by trantow.ben
2 hours ago
Last post by koch.maci
2 hours ago
Last post by qbraun
38 minutes ago
Last post by dejon47
4 hours ago
Last post by volkman.cierra
36 minutes ago
Last post by pfeffer.anika
44 minutes ago
Last post by vicente.bins
1 hour ago
Last post by gladyce05
3 hours ago
Last post by theresa52
2 hours ago
Last post by norris52
3 hours ago
[Q] Help please
Started by mweber
Last post by blick.robyn
2 hours ago
Last post by kbogisich
4 hours ago