"invalid or unsupported own identity" - Advanced VPN Client

Hello.

I have a Galaxy S4 model SCH-I545 with Android 5.0.1. I am trying to use the "Advanced IPsec VPN Client" to connect to my Ubiquiti EdgeRouter's IPsec VPN. I am using certificate-based authentication, and have uploaded the cert/key and CA cert to the phone. I am able to successfully connect using the "Basic VPN Client". However, I am trying to use the Advanced one and am getting the following error upon trying to connect:

"Invalid or Unsupported Own Identity".

There is literally no information on what this error message means; if you put it in quotes on Google you get absolutely zero results on the entire internet. I know the certs are good, since they are able to be used with the Basic client and I can also use them with the Strongswan client to connect to a different router.

So wtf does this error mean? Can provide sanitized configs if needed.

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by qbartoletti
3 hours ago
Last post by raymond73
1 hour ago
Last post by conn.assunta
3 hours ago
Last post by kovacek.tressie
48 minutes ago
Last post by aaliyah38
1 hour ago
Last post by jcrooks
3 hours ago
Last post by qkiehn
3 hours ago
Last post by neoma32
4 hours ago
Last post by little.hermann
3 hours ago
Last post by ferne16
3 hours ago
Last post by fredy68
1 hour ago
Last post by valerie.batz
3 hours ago
Last post by reilly45
3 hours ago